Double clicking over a *.dwg file

General topics relating to CMS IntelliCAD.

Moderator: CMS Inc

CMS Inc
Site Admin
Posts: 74
Joined: Wed Feb 23, 2005 12:01 am

Double clicking over a *.dwg file

Postby CMS Inc » Thu Apr 20, 2017 5:58 am

Some operating systems that run multiple applications able to run *.dwg files may face issues to properly pop&run CMS IntelliCAD by direct DWG file double clicking located at a Windows folder or Windows desktop.

Make sure you to uninstall CMS IntelliCAD , reboot the system and reinstall CMS IntelliCAD again.
Then, right mouse click on top of a dwg file and select > properties > General tab > Press "change" button > click "more apps" > browse to the end of all options and select "Look for another app on this PC". At this point browse for icad.exe at software edition version located, by default, at C:\Program Files\CMS

sln8458
Valued Contributor
Posts: 65
Joined: Mon May 19, 2003 11:01 pm
Contact:

Re: Double clicking over a *.dwg file

Postby sln8458 » Fri May 19, 2017 1:08 am

When I try using the 'double click' method for opening a drawing I receive an error message:

"There was a problem while sending the command to the program"

Intellicad opens in the background, with no drawing loaded, and if I double click on the drawing again it will then open in Intellicad.


Thoughts?
SteveN

gbdesign
Newbie
Posts: 2
Joined: Fri Jul 28, 2017 3:29 am

Re: Double clicking over a *.dwg file

Postby gbdesign » Sat Jul 29, 2017 1:30 am

This is a very late reply to the original post by SteveN, but I had exactly the same problem a few months ago. I was able to solve this eventually, as I discovered that there was an entry in my Windows registry (using Win7 64 bit) which referred to an older version of Intellicad (8.1). Even though I had removed v8.1 last year, the registry key was still there. After I deleted the key and re-installed Intellicad v8.3, the problem was solved.

I'm afraid I don't recall the exact registry key - found it by searching for any keys with "DWG'.

Good luck.
Graeme

gbdesign
Newbie
Posts: 2
Joined: Fri Jul 28, 2017 3:29 am

Re: Double clicking over a *.dwg file

Postby gbdesign » Tue Aug 29, 2017 7:19 pm

Well, after upgrading to Intellicad 8.4, I have once again got the problem of the error message "There was a problem while sending the command to the program". After a bit of internet searching I have discovered how to solve this for Intellicad, which requires a change to the windows registry. Note I am using windows 7 64 bit:

Go to the registry key:

HKEY_CLASSES_ROOT\Icad.Drawing\shell\open\command

On my system the default value was:

C:\Program Files\CMS\IntelliCAD 8.4 Premium Edition Plus\icad.exe /dde

Change this to read as follows (note quotation marks):
"C:\Program Files\CMS\IntelliCAD 8.4 Premium Edition Plus\icad.exe" "%1"

Go to the key:

HKEY_CLASSES_ROOT\Icad.Drawing\shell\open\ddeexec

Delete the default value (which should be Open("%1") ).

Everything is now working fine on my system.


Return to “General”

Who is online

Users browsing this forum: No registered users and 1 guest